1

(2 odpowiedzi, napisanych Ogólne)

U mnie działa przy takich ustawieniach:

https://naforum.zapodaj.net/thumbs/0394f4f69efb.jpg

https://naforum.zapodaj.net/thumbs/4b99a575bbbb.jpg

Zwracam uwagę, że na Onecie jako nazwę użytkownika trzeba wpisać cały adres e-mail a nie tylko sam login!
Mój TheBat to v. 8.8.2.

2

(4 odpowiedzi, napisanych Ogólne)

ARKOM napisał/a:

W moim przypadku to działa tylko po wyświetleniu nagłówka "Odpisz do:"

Ja mam TB v. 8.8.2 i u mnie działa dokładnie tak, jak to Zygmunt opisał.

Ja wyszukuję w poniższy sposób:
Szukaj -  F7, wpisuję Od - allegro, temat - kupiłeś i w wynikach wyszukiwania w polu od jest zawsze powiadomienia@allegro.pl.

Ja założyłem sobie osobny folder "Kupione na Allegro". Jako kryteria filtrowania przyjąłem:

Nadawca zawiera powiadomienia@allegro.pl
Temat rozpoczyna się od:
- Kupiłeś
- Wybrałeś sposób zapłaty
- * otrzymał Twoja wpłatę

3

(19 odpowiedzi, napisanych Ogólne)

przemek napisał/a:
Zygmunt napisał/a:

Zmiana na nazwę bez polskich znaków niczego nie da, ponieważ chodzi tu o znaki takie jak "@" (o kodzie hex 40). Z tego co napisałeś w pierwszym poście wynika, że taki znak jest w nazwie Twojego nadawcy.

Generalnie nie ma, ale chyba WP coś dokleja:(

A z jakiego klienta poczty korzystają ci Twoi korespondencji, z którymi masz kłopot?
Bo jeśli piszą z internetowej strony WP, to tam leży przyczyna i chyba nic się z tym nie da zrobić, bo: https://thebat.pl/forum/viewtopic.php?pid=10165#p10165

4

(19 odpowiedzi, napisanych Ogólne)

Zygmunt napisał/a:

Jak widać - jest różnica: ja używam tabeli znaków iso-8859-a, a Orange używa utf-8. Po zmianie w The Bat! (w szablonie głównym) na utf-8 mamy:

From: =?utf-8?B?UMWCYXRub8WbY2kgT3Jhbmdl?= <moj@adres.pl>
Subject: =?utf-8?B?RHppxJlrdWplbXkgemEgb3DFgmFjZW5pZSBmYWt0dXJ5IHphIHVzxYJ1Z2kgT3JhbmdlIGRs?=
 =?utf-8?B?YSBrb250YSAwMDAwMjQ1NDQ1NDI1OA==?=

U mnie wyszło dokładnie to samo, a TB poprawnie wyświetla mi zarówno nadawcę jak i temat wiadomości.
Trzeba by porównać kompletny tekst źródłowy oryginalnej wiadomości z Orange żeby znaleźć przyczynę problemu.

5

(19 odpowiedzi, napisanych Ogólne)

U ciebie jest całkiem inna sprawa, ten pierwszy mail ma nazwę użytkownika oraz temat zakodowane w formacie Base64 i tych pól TB z jakichś powodów nie zdekodował.
Po zdekodowaniu nazwy nadawcy (https://www.base64decode.org/)  otrzymujemy "Płatności Orange", natomiast zdekodowany "Subject:" to "Dziękujemy za opłacenie faktury za usługi Orange dla konta 00002454454258".

Ze swojego konta na WP, przy użyciu TB wysłałem na swoje inne konto maila z wpisana nazwą nadawcy "Płatności Orange" oraz tematem "Dziękujemy za opłacenie faktury za usługi Orange dla konta 00002454454258".
Po dotarciu maila na drugie konto, TB poprawnie zdekodował zarówno nazwę nadawcy, jak i temat, a nagłówek wiadomości wygląda tak:

====================================
Date: Sun, 28 Mar 2021 12:12:27 +0200
From: =?iso-8859-2?Q?P=B3atno=B6ci_Orange?= <mój_adres@wp.pl>
Reply-To: xxxxxxxxxxxxxxx
Message-ID: <594376834.20210328121227@wp.pl>
To: xxxxxxxxxxxxxx
Subject: =?iso-8859-2?Q?Dzi=EAkujemy_za_op=B3acenie_faktury_za_us=B3ugi_Orange_dla_konta_0000245?=
=?iso-8859-2?Q?4454258?=
MIME-Version: 1.0
Content-Type: text/html; charset=iso-8859-2
Content-Transfer-Encoding: 7bit
=====================================

Widać, że TB wysyłając wiadomości nie stosuje kodowania w formacie Base64, a znaki spoza zestawu ASCII przesyła pod postacią kodów UTF-8.
Co ciekawe, mam liczne maile otrzymywane z BGŻ Optima, gdzie zarówno nazwa nadawcy jak i temat są zakodowane w formacie Base64 i te pola są poprawnie dekodowane przez TB.
Mój TB to v. 8.8.2 (64-bit).

6

(19 odpowiedzi, napisanych Ogólne)

Trochę poeksperymentowałem i w moim przypadku sprawa już jest całkowicie wyjaśniona.
Jeśli nadawca ma konto na WP (lub O2) i do wysyłania poczty używa web-maila, to ten web-mail (User-Agent: GWP-Draft) automatycznie ustawia adres e-mail nadawcy jako jego nazwę i jednocześnie włącza kodowanie UTF-8, chociaż w tej nazwie nadawcy wcale nie ma polskich znaków.  A TB takiej nazwy nadawcy ze znakiem "@" nie dekoduje.

Natomiast jeśli nadawca nie korzysta z web-maila lecz wysyła maile z klienta pocztowego na komputerze, to żadnego problemu nie ma, nazwa nadawcy jest w TB wyświetlana poprawnie bez względu na to, czy zawiera ona PLiterki czy nie, również wstawienie adresu e-mail jako nazwy nadawcy też nic nie psuje.

7

(19 odpowiedzi, napisanych Ogólne)

Jest dokładnie tak, jak to napisano w odpowiedzi od autorów:

"...we have also made the following checks in the display name part of an address: if it contains an "@" character or any control character (with code less than code of a space character), then such a name part is discarded.".

Wszystkie otrzymane przeze mnie maile, w których niepoprawnie wyświetla się nadawca, w polu "nazwa użytkownika" zawierają kod "=40", który odpowiada znakowi "@".
Wszystkie te e-maile pochodzą z kont na Wirtualnej Polsce i w dwóch z trzech przypadków, w nazwie nadawcy zawierają PLiterki. Ale oprócz tego mam też maile z innych kont na @wp.pl, które też zawierają PLiterki w nazwie, a pomimo tego w kodzie źródłowym nie maja znaku "@" i te wyświetlają się poprawnie co sugeruje, że problem może leżeć w konfiguracji konta na wp.pl.

8

(19 odpowiedzi, napisanych Ogólne)

Ja też mam trochę e-maili obarczonych tą samą wadą i to co je łączy to fakt, że wszystkie one zostały nadane z kont na Wirtualnej Polsce oraz ten sam User-Agent: GWP-Draft.
Nazwa nadawcy wygląda tak:
From: =?UTF-8?Q?wieslaw=2Exxxxxx=40wp=2Epl?= <wieslaw.xxxxxx@wp.pl>
więc żadnych znaków sterujących tu nie widzę.

9

(13 odpowiedzi, napisanych Ogólne)

Ja na aż tak drastyczne kroki nie jestem gotów.
Do obsługi konta Gmail zainstaluję sobie Firebirda, TB będę używał dopóki się da, ale "Dziewiątki" na pewno nie kupię.
Biorę pod uwagę również istotne ograniczenie korzystania z Gmaila, bo działania Googla coraz bardziej mnie irytują.

10

(13 odpowiedzi, napisanych Ogólne)

Wygląda na to, że koniec wsparcia TB dla Gmaila z wolna stał się rzeczywistością.
Od 8 kwietnia mój TB 8.8.2 przestał ściągać pocztę z konta Gmail sad
Firebird obsługuje konto Gmail w dalszym ciągu.